Welcome, Guest
Username: Password: Remember me

TOPIC: Mojave 10.14.6 and Final Cut

Mojave 10.14.6 and Final Cut 25 Jul 2019 17:56 #100589

I just got a new macbook pro that has Mojave 10.14.6 installed, and I'm running Final Cut 10.14.6

It worked fine for about a day, but when I opened a library today it will load fine, but wont actually play anything. I get the rainbow wheel for a while, then the viewer will show the option to pause (like it is playing) but nothing plays - and anytime you move the playhead or try and open any panels it just gets the spinning wheel for a while then doesn't do anything.

Anyone else having problems?
The administrator has disabled public write access.

Mojave 10.14.6 and Final Cut 28 Jul 2019 13:10 #100626

  • FCPX.guru
  • FCPX.guru's Avatar
  • OFFLINE
  • Platinum Boarder
  • bbalser.com
  • Posts: 2725
  • Thank you received: 359
  • Karma: 33
What are your hardware specs?

First thing I'd do is launch FCPX while also holding down the Command and Option keys together. Delete preference files. It's perfectly safe.

Once FCPX has launched, don't touch anything, go directly to Preferences, turn off Background Rendering.

Next, select the Library in the Browser, go to the File menu, "Delete All Generated Library Files" and in that window, delete ALL render files.

Quit, relaunch, see if that helps.
The administrator has disabled public write access.

Mojave 10.14.6 and Final Cut 28 Jul 2019 18:57 #100633

  • joema
  • joema's Avatar
  • NOW ONLINE
  • Platinum Boarder
  • Posts: 1192
  • Thank you received: 245
  • Karma: 21
Besides what FCPX.guru said, verify you are not running the Chrome browser. There is a known incompatibility between newer versions of Chrome and FCPX. This is caused by Chrome monopolizing the VideoToolBox framework, thereby locking out FCPX and causing lags and hangs.
The administrator has disabled public write access.