Welcome, Guest
Username: Password: Remember me

TOPIC: Transform animation doesn't work as expected

Transform animation doesn't work as expected 01 Aug 2019 18:37 #100693

  • bzmot
  • bzmot's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
Hi guys, I'm new here so bear with me if this has been discussed before.

I have compiled a little vacation video:

vimeo.com/350963538?utm_source=email&utm...2HEC34RiZ9JOFGCCv_Hc

And in the first section (header) I tried to animate several different clips to create a gradually building video wall. However, as you can see the effect is far from perfect. Ideally the clips should resize and move together as if glued. They got the same keyframes and the values are correct. But they don't seem to be animated at the same speed or at an even speed and also for some reason for example when one of the clips is supposed to move only along the X axis, it does go down a little on the Y axis during its animation. It does end at the desired place as defined by the keyframe but the road it takes to get there is... unpredictable. Why does FCPX keep doing that? I am confused. When I establish two keyframes, on one the position of the clip is X 2880, Y 0 ands on the next one: X 960, Y - still 0. But between those two keyframes FCPX somehow at some points animates the clip down to -30 on the Y axis. And it doesn't look pretty. Like I told you, the clip ends in the set location by the next keyframe but I don't like the way it moves... Any solutions? Much appreciated!
The administrator has disabled public write access.