Welcome, Guest
Username: Password: Remember me

TOPIC: BruceX: Try this new Final Cut Pro X benchmark

BruceX: Try this new Final Cut Pro X benchmark 30 Oct 2013 16:10 #33495

  • freeform
  • freeform's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 66
  • Thank you received: 2
  • Karma: 1
MacPro 4,1 early 2009 1x2.66 GHz Quad-Core
20 GB ram
pathetic stock NVIDIA GeForce GT 120 512 MB
(I know, this is my biggest problem. I've been shopping for the best price/performance GPU to match my system. Probably get a 2-3 gig Radeon, just hope to get another year out of this beast before I get a new MP.)

Test: I stopped after it was barely 1/3 done after 5 min. :blink:
I'm embarressed for my machine... :blush:
(Though it does resonably fine all my pro media work except for med-complex FCPX work. )
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 30 Oct 2013 16:34 #33497

  • alex4D
  • alex4D's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 465
  • Thank you received: 250
  • Karma: 36
freeform,

If your clients aren't complaining and you can get your work done without too much waiting, your machine is fine!

www.barefeats.com

is the place to go to see what GPU and memory upgrades can do for Mac Pros.

If you then wait until the second generation of the new Mac Pro, most design problems will have been ironed out.


@Alex4D
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 30 Oct 2013 17:00 #33500

  • freeform
  • freeform's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 66
  • Thank you received: 2
  • Karma: 1
Thanks Alex... yup, that's what I've been thinking. Lukily I'm not doing a lot of compositing these days. I just wish a 2-3 gig Mac Radeon would drop in price from the 450 range to the 250 PC price. I might try flashing a PC version.
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 30 Oct 2013 17:29 #33501

  • Darren Roark
  • Darren Roark's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 481
  • Thank you received: 61
  • Karma: 13
Is it possible there is some kind of alpha channel flag set in this file? I know that an h264 doesn't have an alpha channel, but is QT seeing something wrong?
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 30 Oct 2013 17:34 #33502

  • alex4D
  • alex4D's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 465
  • Thank you received: 250
  • Karma: 36
The 5K H.264 'black playback' problem is a repeatable bug in QuickTime playback that is worth reporting to Apple.
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 30 Oct 2013 18:14 #33503

  • daviddelreal
  • daviddelreal's Avatar
  • OFFLINE
  • Gold Boarder
  • Posts: 238
  • Thank you received: 10
  • Karma: 4
Early 2011 15" Macbook Pro
2.2 Ghz quad core i7
16 GB RAM @ 1600 Mhz
AMD Radeon HD 6750M 1GB
Dual SSD setup (SSD for boot drive and SSD in optical space)
Exported to 480GB SSD internal scratch (optical space)
OSX !0.9 Mavericks
126 seconds
Last Edit: 30 Oct 2013 18:15 by daviddelreal.
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 31 Oct 2013 02:23 #33520

  • BenB
  • BenB's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 10106
  • Thank you received: 1279
  • Karma: -34
Brand new 2013 15" rMBP
2.6 Ghz i7
16 GB RAM
1TB PCIe-based Flash Storage
Mavericks
Integrated: 2:41.0, or 181 seconds
Discrete: 1:27.0, or 87 seconds (fan kicked in very loud, too)
Last Edit: 31 Oct 2013 13:06 by BenB.
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 31 Oct 2013 05:40 #33522

  • ddixon
  • ddixon's Avatar
  • OFFLINE
  • Gold Boarder
  • Posts: 262
  • Thank you received: 48
  • Karma: 4
2008 Mac Pro (3.1) 8 core 2.8 mhz
12 GB RAM
Radeon 5870
Internal 2 TB HDD
Mountain Lion
200 seconds

Not as good as expected. Also when trying to play the timeline, I get 15 seconds of spinning beach ball then ultra choppy playback. Some of this may be due to only 12mb RAM, but I haven't upgraded because…

Being delivered Saturday - iMac 3.5 i7 with 8gb RAM (16 more on the way).
Last Edit: 31 Oct 2013 05:42 by ddixon.
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 31 Oct 2013 11:49 #33536

  • jjsanderson
  • jjsanderson's Avatar
  • OFFLINE
  • Gold Boarder
  • Posts: 183
  • Thank you received: 28
  • Karma: 7
ddixon wrote:
2008 Mac Pro (3.1) 8 core 2.8 mhz
12 GB RAM
Radeon 5870
Internal 2 TB HDD
Mountain Lion
200 seconds

Similar system: 116 secs.
Differences: 18Gb RAM (which iStat Menus didn't indicate was being used), and Mavericks.

My 5870 is driving two displays. I wonder if it goes any faster with just one?
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 31 Oct 2013 11:53 #33537

  • Dave_EP
  • Dave_EP's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 388
  • Thank you received: 37
  • Karma: 6
jjsanderson wrote:
ddixon wrote:
2008 Mac Pro (3.1) 8 core 2.8 mhz
12 GB RAM
Radeon 5870
Internal 2 TB HDD
Mountain Lion
200 seconds

Similar system: 116 secs.
Differences: 18Gb RAM (which iStat Menus didn't indicate was being used), and Mavericks.

My 5870 is driving two displays. I wonder if it goes any faster with just one?

And my system with 5770, 16GB and Mountain Lion (also dual display) is :
MacPro 3,1 8 core 2.8Ghz (early 2008) 16GB 5770 (1GB) - 133 seconds

So there's something wrong with your system at 200s. What else do you have running?
Last Edit: 31 Oct 2013 12:01 by Dave_EP.
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 31 Oct 2013 13:01 #33541

  • ddixon
  • ddixon's Avatar
  • OFFLINE
  • Gold Boarder
  • Posts: 262
  • Thank you received: 48
  • Karma: 4
OK, sorry - I did that 2008 8-core test last night in haste after a long day - had Photoshop, iDVD, Safari, etc. also open. The MacPro has an internal 256 SSD boot drive and I set my internal 2TB Hitachi media drive as the destination drive.

So, re-running the test this morning after a fresh reboot, I now get 123 seconds. And, using the SSD boot drive as the destination for the test export gets the same result. Again, Radeon 5870 and 12 gb RAM.

I'll re-run the test this weekend with my new 3.5Ghz iMac. I can run it out-of-the-box on the 1TB Fusion Drive with 8gb RAM, then again with 24gb RAM, then again with two 2 TB drives as a RAID 0 in an external Thunderbolt enclosure.
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 31 Oct 2013 13:09 #33543

  • BenB
  • BenB's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 10106
  • Thank you received: 1279
  • Karma: -34
If you have two monitors connected, yes, the GPU is allocating half of it's resources to the second monitor, and FCP X only accesses the resources allocated for the main monitor. Disconnect the second monitor, reboot, run the test again.
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 01 Nov 2013 00:34 #33575

  • rune
  • rune's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • Thank you received: 1
  • Karma: 0
MBP Retina Mid 2012 (MBP 10,1) i7 2.7 GHz / 16 GB RAM / GT650M 1GB / 768 GB SSD

My machine only got 152-154 seconds (144 seconds if only background render just for the heck of it)

Just for the heck of it i tried a variety of settings to see how it impacts:
- Different Retina scaling settings
- Using the machine for other tasks during the export (basic browsing and Numbers/Pages, nothing special)

None of those did much to change the outcome. Also for a "seconds per frame" project the codec doesn't make much impact (I got the same exact results with ProRes 422/4444 and h.264). The 4444 took a second or so more.

Fun little project, reminds me of the pirate ship in the full moon project from Shake times for those who remember that . :-)

-rune
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 01 Nov 2013 01:48 #33577

I got about 103 seconds.

2009 2.93Ghz 8-Core
26GB RAM
5870 1GB
7200rpm Main HD (rendered to secondary HD)

I'm a little confused by the results. I've done some testing with Barefeats, with him running a test of my own in Premiere across multiple machines. My machine was stacking up 25% faster then the latest gen iMac maxed out on a consistent basis. In this test I'm getting beat by 2011 MacBook Pro's and the latest iMac's. Why is that? What is the issue here? I've checked to make sure I don't have anything crazy intensive running. I have 1 monitor only (24in), I only have the one project/event open (using Event Manager X), etc. I've tried to figure this out but can't seem to. Why is my machine so far behind?

It seems to me these tests at times are very subjective and depending on what sort of test you do the results machine to machine are going to vary greatly...especially "real world" tests. If video ram alone is most of the factor in this test then it makes sense that these newer machines beat mine. I wish I had a 7970 to throw in there to test again. There are days I feel like I need to upgrade and other days I think I'm doing just fine on this machine.

I wonder if internal storage plays a big factor in this specific benchmark, not just GPU and GPU RAM? Storage doesn't normally make a huge difference though...not in my experience.

Thoughts Alex?
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 01 Nov 2013 02:31 #33578

  • ddixon
  • ddixon's Avatar
  • OFFLINE
  • Gold Boarder
  • Posts: 262
  • Thank you received: 48
  • Karma: 4
kyleprohaska:

I think you're mis-reading. There are no MacBook Pros in this entire thread that got a faster speed than your 2009 MacPro score of 103 except for a couple of brand new late 2013 top end models at 88 or so. Several of us have 2008 MacPros and are scoring in the 125-135 range. Other Macbook Pros that are <2 years old are scoring in the 145-155 range. And 2011 MacBook Pros are just giving up rather than finishing the test.

Now iMacs - that's a different story. The very fastest 2012 and 2013 iMacs are scoring in the 50-60 range with a mid-2011 top iMac at 78. And another 2009 MacPro got 103 like you. Yet another 2009 MacPro with a lesser video card even gave up on the test.

Even a 2011 MacBook Pro with all SSD drives just got 126.

So yours is pretty much as expected. And, mentioning barefeats.com - they have been showing in testing for a year or so that the top end 2012 and 2013 iMacs can easily outpace a MacPro from 2011 or earlier in most tasks, and can keep up even with newer towers that are <12 cores.

Despite the instructions from Alex about running this to your fastest drive, I think this is primarily a test of raw rendering power done by the CPU and GPU in combination.

I'm curious about other factors. I'm getting a new iMac Saturday (fastest BTO option) and plan to run this again on that with different amounts of RAM and with 1 TB fusion drive vs. an external Thunderbolt RAID.
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 01 Nov 2013 02:37 #33579

  • Redifer
  • Redifer's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 798
  • Thank you received: 73
  • Karma: -2
Mac Pro 1.1 from 2006.
2 x 2.66Ghx dual-core Intel Xeon
8 GB 667 Mhz DDR2 RAM
ATI Radeon 5770 graphics card with 1GB VRAM
Mac OS 10.6.8

200 seconds.
Last Edit: 01 Nov 2013 02:38 by Redifer.
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 01 Nov 2013 12:15 #33587

  • qbe
  • qbe's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
  • Thank you received: 2
  • Karma: 1
Hackintosh
Ivy Bridge 4.2GHz
32GB RAM
AMD 7970 3GB
time 30.5

Saving to regular SATA HD/RAID/SSD made no difference for me. First part of test is GPU, second is CPU transcoding to h264. Ram and Vram usage accordingly.

Going with one display or two displays, makes no difference on my setup.

kyleprohaska: Every real world test is very situational, from results i assume amount of VRAM makes big difference. There is only slight speed bump going from 650m to 750m, yet you can see the big difference in time. There is 2GB of VRAM in 2013 rMBP but 1GB VRAM in 2012 rMBP. I think this also aplies to your powerful 5870, but only 1GB VRAM.

So in the end, in this particular scenario your MP is behind, but in lighter workload situations you are perfeclty fine...

Just wanted to note, even though i have great result, the project cannot be played in realtime without serious stuttering. It is a very very intensive bench.
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 01 Nov 2013 20:13 #33594

  • Darren Roark
  • Darren Roark's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 481
  • Thank you received: 61
  • Karma: 13
Did you overclock your Hackintosh to 4.2? What logic board do you have?
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 01 Nov 2013 21:20 #33599

  • Dave_EP
  • Dave_EP's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 388
  • Thank you received: 37
  • Karma: 6
BenB wrote:
If you have two monitors connected, yes, the GPU is allocating half of it's resources to the second monitor, and FCP X only accesses the resources allocated for the main monitor. Disconnect the second monitor, reboot, run the test again.

Interesting.

MacPro 3,1 8 core 2.8Ghz, 16GB, 5770 (1GB)

• Two Monitors 133 seconds

• One Monitor 113 seconds

That's an 15% increase in speed by dropping the second monitor (freeing up GPU ram). Even more reason to upgrade the GPU with more ram in future.
The administrator has disabled public write access.

BruceX: Try this new Final Cut Pro X benchmark 03 Nov 2013 04:33 #33620

I must have something terribly wrong with my iMac.

I have a 2011 iMac, Max Spec BTO
3.4 i7
16Gbs of 1333 Mhz DDR3
AMD 6970 with 2GBs
Running 10.9
Running an 8GB Thunderbolt Raid from G-Tech

However when I run this test... my results are WAY off.
I am trying to figure out why.

Even though I have the same computer with the same setup as the OP, instead of getting 75-80 seconds...I have been getting times in the multiple minute range. What is wrong?

First test with three monitors being driven. 5 minutes 19 seconds.
Second Test with one monitor...before rebooting....3 minutes 57 seconds.
Third test with one monitor...after rebooting.... 3 minutes 19 seconds.
Not really sure what could be making my setup run twice as slowly as it should?

Thoughts? Suggestions or does it sound like something may be wrong hardware-wise.

Any thoughts from the brain trust here at FCP forums would be greatly appreciated.

Scratching my head here.
Going to run it one more time.

*** Ran a fourth test and hit 3 minutes 18 seconds again.
**** Ran a fifth test on a 2008 MP with an upgraded 5770, SSD and 8GBs of RAM, my other 8GB module died....this test on the other older machine - writing to the SSD finished in 3 minutes 20 seconds. Now I am very worried something may be wrong with my iMac as it should be posting much faster times than this.

Any help/suggestions are welcome.
Last Edit: 03 Nov 2013 04:53 by clintstuckey.
The administrator has disabled public write access.