Welcome, Guest
Username: Password: Remember me

TOPIC: Exporting file stuck at 88% (to masterfile) and crashing when editing

Exporting file stuck at 88% (to masterfile) and crashing when editing 07 Jan 2017 02:21 #84602

  • dgwvideo
  • dgwvideo's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1909
  • Thank you received: 224
  • Karma: 31
27GB of free space is the bare minimum (10%) of what your drive needs function properly, and maybe 15% to 20% would be recommended for your computer spec. I would try two things if you can:
1. Delete a few clips in the timeline each side of the 2 minute 52 second mark and try again. You may not be able to tell if a clip is corrupted, but if you delete a few of these and the export finishes, likely one of those clips is problematic.

2. Find a fast external drive that has plenty of room for your export and share to that. If the export finishes on an external drive then you've ruled out an issue with any clips or your project.

Post back the results of either or both tests.
Creating history....one edit at a time !
The administrator has disabled public write access.

Exporting file stuck at 88% (to masterfile) and crashing when editing 17 Dec 2018 23:42 #98193

  • yunebug
  • yunebug's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
EDIT: Since the original post has now become "k", I guess I'll elaborate. When exporting a project, the share process gets hung up at 88% and does not progress further. When attempting to stop the share process, I get the spinning umbrella and have to force-quit the program. Upon relaunch, I delete generated event files and export again. Most of the times, that resolves the problem, but sometimes not. And this seems to be completely at random - some projects will export just fine and others will hang.

Sorry to dig this up, but the same thing is happening to my Final Cut Pro X.

MacBook Pro Retina Mid-2012
i7 2.6GHz
8GB RAM
500GB SSD with 260GB free
Mojave 10.14.2
FCP 10.4.4

It used to be a random event, which was resolved by deleting generated event files, force quitting the program, and exporting again, but it seems to be happening more intermittently now. The randomness is becoming more consistent, which leads me to believe that it will be a consistent/permanent thing in the near future.

My scope of work is importing an mp4 of about 500MB (5-6minutes) and putting it together with a voiceover wav file (44.1KHz, 16-bit, mono). Export to 1080p mp4. No layers, no effects, no transitions - relatively simple and straight-forward tasks.

I'd love your thoughts on it. Thank you in advance for your time.
Last Edit: 19 Dec 2018 04:33 by yunebug. Reason: Elaborating what happens
The administrator has disabled public write access.

Exporting file stuck at 88% (to masterfile) and crashing when editing 20 Dec 2018 15:31 #98237

  • DmitriZigany
  • DmitriZigany's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 643
  • Thank you received: 24
  • Karma: 1
yunebug wrote:
EDIT: Since the original post has now become "k".
And the user that posted is using my profile pic!? Or is that another bug and only I see that???
The administrator has disabled public write access.

Exporting file stuck at 88% (to masterfile) and crashing when editing 20 Dec 2018 16:53 #98240

  • dgwvideo
  • dgwvideo's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1909
  • Thank you received: 224
  • Karma: 31
must be a bug.. (or a hack) - In trying to respond to you I now see that my profile pic suddenly appears in the OP's previously blank avatar. The moderators need to look into this.
Creating history....one edit at a time !
Last Edit: 20 Dec 2018 16:54 by dgwvideo.
The administrator has disabled public write access.

Exporting file stuck at 88% (to masterfile) and crashing when editing 20 Dec 2018 18:11 #98241

  • yunebug
  • yunebug's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
Yes, my avatar has also gone blank as well.

Following instructions from Apple (Mavericks version), I've uninstalled FCP and re-installed it. I've also created new libraries and projects from the newly reinstalled FCP. This seems to have helped as I have not experienced the 88% hangup (yet). If the problem returns, I will report back.
The administrator has disabled public write access.

Exporting file stuck at 88% (to masterfile) and crashing when editing 01 May 2019 07:06 #99861

  • edwardbuck
  • edwardbuck's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
Was wondering if anyone had found a solution to this bug. I'm having the same issue as the others with FCPX getting stuck at 88% and having to force close the app. Doesn't happen all the time, just on random exports. I notice it most often if I have several exports in the queue and then leave for the day. I arrive in the morning expecting it to be complete and partway through the list, it hung at 88% on one video, therefore not finishing the exports.

I have also noticed that fcpx is running a little slower all around (exports take longer, more spinning beachballs, less responsive to clicks). I use this iMac almost exclusively for FCPX so I haven't noticed the lag in other programs.

I'm editing 28 minute TV programs exporting to 1080p MOV files (about 3GB). The problem is only occurring on one iMac (the newer faster one).

iMac with the issue:
iMac Retina 4K late-2015
i7 3.3GHz
16GB RAM
1tb HDD
external 4tb USB3 Maxtor drive
Mohave 10.14.4
FCPX 10.4.6

Other iMac working fine:
iMac mid-2014
i5 1.4GHz
8GB RAM
256GB SSD
Mohave 10.14.4
FCPX 10.4.6

I'd appreciate any suggestions. I may just have to wipe it and reinstall everything from scratch.
The administrator has disabled public write access.

Exporting file stuck at 88% (to masterfile) and crashing when editing 29 Jun 2019 08:42 #100328

I am getting exactly the same thing - freezing at 88% when exporting and it is getting worse. Trying to trim some simple clips to mp4 for Shutterstock. Yes sometimes deleting and starting again worked.
The administrator has disabled public write access.

Exporting file stuck at 88% (to masterfile) and crashing when editing 29 Jun 2019 23:05 #100331

  • joema
  • joema's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1262
  • Thank you received: 263
  • Karma: 22
First make sure you have plenty of free space on all drive volumes including the system drive. If you have not run Disk Utility First Aid on all volumes, do that. Rebuild Spotlight indexes on all drives using this procedure: support.apple.com/en-us/HT201716

Make a snapshot of your current project: right click, select "duplicate as snapshot". Open that, strip all effects from it by selecting all clips and doing Edit>Remove Effects. Try to export that and see if it ever hangs. If yes, it may be an effect or a corrupt render file.

Try deleting all your render files, and also consider doing this for proxy or optimized media if possible. A render or corruption problem can become embedded in those generated files. You can delete only the render/proxy/optimized media from the timeline, not the entire library. Select the project thumbnail in the Browser, then File>Delete Generated Project Files. Once the problem is solved if you need the proxy or optimized files for subsequent editing performance, you can rebuild those.

After deleting all render files, restart FCPX. If the export does not halt on the timeline without effects, open the regular timeline and fully render it by selecting all clips and doing CTRL+R. Does that ever hang?

Export consists of two phases, rendering and encoding. Rendering the timeline first helps isolate what phase the hang happens in.

If the render halts at a certain point such as +40 min into the timeline, zoom way in and inspect that region closely. Make sure there are no visible black frames. Make sure playback works on that region with no skipping, lagging or other anomalies.

If that works and doesn't show visible problems, draw a range box around the problem region, say 10 min long, then try to export that one problem region.

If that works but exporting the full timeline to a file still halts at the same place, import a new copy of the clip, copy the timeline clip attributes with CMD+C, then match the timecode from the timeline clip to the new copy in the Event Browser and do a 3-point replace edit. You then add the original clip attributes to the new clip via Edit>Paste Attributes and select which ones you want added. The avoids having to manually add them by hand. You can also do a connect edit (Q key) on top of the old clip, then use the V key to disable the original clip to verify the sync. If OK use the P key (Position Mode), and drag down the new connected clip to overwrite the original clip. Then re-try the export.
Last Edit: 29 Jun 2019 23:07 by joema.
The administrator has disabled public write access.

Exporting file stuck at 88% (to masterfile) and crashing when editing 10 Oct 2019 07:43 #101963

  • paulmurp
  • paulmurp's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
One thing you may like to check is the name of your file. I've experienced the same and traced it to a "/" in the name of one of my clips (as in ...export/import...) - which was the one I was hanging on. My full export world without a problem. Renaming my clip to replace the / did the trick.
The administrator has disabled public write access.