fbpx
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Frame Drops when "Shared"

Frame Drops when "Shared" 27 Sep 2017 13:12 #90825

  • twrench58
  • twrench58's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 0
But when I render, I get random frame drops. Like 1 or 2 in a 20 minute segment.

I have no frames drops when working in FCPX.

I will have a B-roll clip placed above the magnetic time line and during rendering, one frame from that clip will be dropped and the video from the magnetic timeline will be revealed.

Apple blames Red Giant MAGIC BULLET SUITE 13 or Pegasus2 Promise Raid

Anyone have this issue.

System
FCPX: V 10.3.4
iMac (27-inch, Late 2013)
3.5 GHz Intel Core i7
32 GB 1600 MHz DDR3 RAM
NVIDIA GeForce GTX 780M 4096 MB
One FW2 connection: 2 Pegasus2 Promise Raid
Only plug-in Red Giant MAGIC BULLET SUITE 13

Please Log in or Create an account to join the conversation.

Frame Drops when "Shared" 28 Sep 2017 11:15 #90848

  • FCPX.guru
  • FCPX.guru's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • bbalser.com
  • Posts: 3008
  • Karma: 34
  • Thank you received: 402
What is the source of the footage?
What codec/format are you exporting it as?

Are you saying you're working on a Firewire drive?

Please Log in or Create an account to join the conversation.

Last edit: by FCPX.guru.

Frame Drops when "Shared" 28 Sep 2017 13:06 #90851

  • twrench58
  • twrench58's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 0
Source files are ProRes 442 HQ 1920x1080

Shared files are ProRes 442 HQ 1920x1080 OR H264 1920x1080

If happens with both files.

Would I have less issues / better quality to export with Compressor?

Drive connection is a Thunderbolt 2

Attached are the speed test on the internal and external drives

Please Log in or Create an account to join the conversation.

Frame Drops when "Shared" 28 Sep 2017 23:33 #90856

  • joema
  • joema's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1341
  • Karma: 27
  • Thank you received: 279

twrench58 wrote: ....I will have a B-roll clip placed above the magnetic time line and during rendering, one frame from that clip will be dropped and the video from the magnetic timeline will be revealed....


By "during rendering", do you mean after rendering or after exporting, a single-frame gap appears in the connected clip which shows the underlying timeline? Is this in the middle of the connected clip or on the head/tail? Is it possible you have two adjacent connected clips and there's a single-frame gap between them which you recently noticed?

Please Log in or Create an account to join the conversation.

Frame Drops when "Shared" 29 Sep 2017 20:20 #90875

  • twrench58
  • twrench58's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 0
>Is it possible you have two adjacent connected clips and there's a single-frame gap between them which you recently noticed?

Nope it is one solid clip with no

>By "during rendering", do you mean after rendering or after exporting,

After sharing as Apple calls it.

>a single-frame gap appears in the connected clip which shows the underlying timeline?

Yes that is what is happening.

Please Log in or Create an account to join the conversation.

Frame Drops when "Shared" 30 Sep 2017 12:11 #90883

  • joema
  • joema's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1341
  • Karma: 27
  • Thank you received: 279
>>>one frame from that clip will be dropped and the video from the magnetic timeline will be revealed.

>>a single-frame gap appears in the connected clip which shows the underlying timeline?

> Yes that is what is happening.

Is this the same frame each time or is it truly random? Is the position of the dropped frame in roughly the same timeline region of the connected clip? Does this happen with only a single connected clip or does it happen with more than one?

Has this always been happening or did it start recently? What version of macOS are you running?

If you render the timeline (CMD+A to select all, then CTRL+R to render), then export it as a separate step does this still happen? What codec are you exporting to?

Magic Bullet Suite 13 has several different effects. Can you determine by testing which one of those might be causing the problem? E.g, if you are using several on both main storyline and connected clip, disable them one at a time until you find which is causing the problem.

It also wouldn't hurt to delete all generated library files and rebuild those.

Please Log in or Create an account to join the conversation.

Frame Drops when "Shared" 09 Oct 2017 17:25 #91048

  • twrench58
  • twrench58's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 0
>>>Is this the same frame each time or is it truly random? Is the position of the dropped frame in roughly the same timeline region of the connected clip? Does this happen with only a single connected clip or does it happen with more than one?

It will drop the same frame. If I cut the main timeline and move the b-roll down, it renders fine.

>Has this always been happening or did it start recently? What version of macOS are you running?

About a month ago. Nothing new was updated.

10.12.6

If you render the timeline (CMD+A to select all, then CTRL+R to render), then export it as a separate step does this still happen? What codec are you exporting to?

Yep, still happens.

>Magic Bullet Suite 13

Only Magic Bullet Film

>It also wouldn't hurt to delete all generated library files and rebuild those.

Done that. Do it a lot.

Please Log in or Create an account to join the conversation.

Frame Drops when "Shared" 10 Oct 2017 23:05 #91065

  • joema
  • joema's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1341
  • Karma: 27
  • Thank you received: 279

twrench58 wrote: >>>Is this the same frame each time or is it truly random? Is the position of the dropped frame in roughly the same timeline region of the connected clip? Does this happen with only a single connected clip or does it happen with more than one?

>It will drop the same frame. If I cut the main timeline and move the b-roll down, it renders fine....Magic Bullet Suite 13...


It's interesting that it's the exact same frame each time. From a troubleshooting standpoint, something that's consistently reproducible is good. If I had Magic Bullet I would try it myself. I've thought about getting it but the only Red Giant product I have is Plural Eyes.

Have you contacted Red Giant? I've had pretty good experience with their support.

Beyond this, your options include doing more tests, trying other machines, trying different timelines and codecs, etc. Narrowing it down is unfortunately tedious work but it often leads to workarounds, isolation of the guilty party and faster response from the developer.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1