Welcome, Guest
Username: Password: Remember me

TOPIC: FCPX stops responding to playback commands.

FCPX stops responding to playback commands. 28 May 2019 17:31 #100038

  • raphael
  • raphael's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 1
  • Karma: 1
FXPX 10.4.6 on MBP OS10.14.4. Project loads in OK, editing a 2 cam multiclip works smoothly, and then after about 10 minutes or a handful of edits, abruptly stops responding to space bar, or Cmd L or J. Nothing moves. Only workaround is quitting, and then restarting FCPX. Same scenario - works fine for while, and then stops responding.
Been using FCP since v.1.0, all through fcp 7.0 and FCPx. Been editing since early 80's on NLEs.
Edited a 2 hour show on the same exact hardware/software (with the exception of upgrading to 10.14.4, with footage from the same acquisition sources, only a month ago, with no apparent problems.
Anyone have any insights?
I am getting tired of quitting FCPx every 10-15 minutes. It's getting old pretty quickly.
Thank You.
The administrator has disabled public write access.

FCPX stops responding to playback commands. 29 May 2019 13:52 #100042

  • Doug
  • Doug's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 40
  • Thank you received: 7
  • Karma: 1
That's a very weird problem! If you've already cleared all your render files, checked that your hard drives that the media is stored on are not deteriorating, and trashed your FCPX Preferences, I would suggest doing a re-install of FCPX.

Best of luck, let us know if/how you're able to solve this problem!
The administrator has disabled public write access.

FCPX stops responding to playback commands. 29 May 2019 19:38 #100051

  • raphael
  • raphael's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 1
  • Karma: 1
Thanks for the suggestions. I had tried everything on the list, except trash/reinstall FCPx. Just trashed & re-installed FCPx from the App store. Problem still persists.

Updated to OS 10.14.5, even though not a good idea during a project. NaDA!

I logged all the unresponsive events today: 10 no-response events in 2.5 hours. As soon as I quit/ restart FCPx, everything works like usual. Best= 29 mins, worst=8 mins before the app stops responding to play commands. I can still click around, select clips, change settings, almost anything I want to do, except get the playhead moving - in the timeline or the browser using the keyboard or menu commands. Audio files, Video/audio, or video only. No response to space bar, menu or J, K, L

I can click on the timeline to move the playhead to the clicked position, but can't make it play.

All I can think is that I installed DaVinci Resolve 16 a week ago, and started experimenting with it because of all the good reviews out there.
Perhaps Apple is jealous?

If I ever get to finish this current project, I'll be seriously considering Resolve.
The administrator has disabled public write access.

FCPX stops responding to playback commands. 30 May 2019 03:03 #100055

  • smg669
  • smg669's Avatar
  • OFFLINE
  • Gold Boarder
  • Posts: 190
  • Thank you received: 25
  • Karma: 0
Hey, I think I'm experiencing the same issue. iMac late 2015, OSX 10.14.5, FCPX 10.4.6. When it happens to you, are you unable to click/drag the playback head in the timeline and skimming stops working on the timeline – but still works in the event browser?

Just started happening recently after updating my OS and FCPX one after the other.

Trashed FCPX preferences. Haven't tried a clean re-install of FCPX or the OS yet.

S
The administrator has disabled public write access.

FCPX stops responding to playback commands. 30 May 2019 08:26 #100056

  • Rinaldo Doon
  • Rinaldo Doon's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 2
  • Karma: 2
There are two things worth trying. One is to reset the SMC - System Management Controller. In my experience, this can cure a multitude of strange issues including those mentioned in the support document and some that aren't, and I find it particularly useful on MacBook Pros. Secondly, there is the old favourite of resetting the PRAM - Programmable RAM. This resets various low-level system settings and is always worth a try when having issues. I would do this after the SMC reset. The only visible up-front settings that get reset are the speaker volume and the screen brightness, but there are some other important parts of the system that are cleaned-up.

You don't say which MBP you have, so in the Reset SMC document, look up the specific method for your Mac.

Reset SMC
support.apple.com/en-gb/HT201295

Rest PRAM
support.apple.com/en-gb/HT204063

Hope this helps.
The administrator has disabled public write access.

FCPX stops responding to playback commands. 06 Jun 2019 11:03 #100125

  • Stasinos
  • Stasinos's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 24
  • Thank you received: 1
  • Karma: 0
I have a similar problem. In my case no video file will play in FCPX, VLC, Quicktime and even Safari. Until last week the only workaround was to restart my computer.

This week i tried to unplug and plug again my external audio device (M-Audio M-Track) and the problem was solved. If i switch to internal audio card from the settings the problem also disappears. So in my case it has to do with the Mojave update along with external audio.

I have also serious bluetooth connection problems (after mojave update) as my magic mouse and keyboard tend to disconnect after waking up from sleep.

Do you have an external sound device connected?
The administrator has disabled public write access.

FCPX stops responding to playback commands. 07 Jun 2019 00:11 #100137

  • Redifer
  • Redifer's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 787
  • Thank you received: 70
  • Karma: -2
This is a common problem. You don't need to completely quit FCP, just double-click on the project in the browser. The project/timeline reloads and all is well. This usually happens when copy/pasting transitions, I find.
The administrator has disabled public write access.

FCPX stops responding to playback commands. 23 Jun 2019 22:46 #100284

  • smg669
  • smg669's Avatar
  • OFFLINE
  • Gold Boarder
  • Posts: 190
  • Thank you received: 25
  • Karma: 0
Redifer wrote:
This is a common problem. You don't need to completely quit FCP, just double-click on the project in the browser. The project/timeline reloads and all is well. This usually happens when copy/pasting transitions, I find.

I don't think that is the issue being described. At least it isn't for me. Double clicking to re-open the same Project (or even a different project) does not solve the issue.

After a period of time, when try to I execute playback of the main timeline (either using the Spacebar or Menu Command) I get a brief instance of cursor beachball and then no playback. FCPX in general becomes sluggish. Same thing happens with trying to playback source clips in the Event Browser.

If I restart FCPX (just the app - not the whole system) all is back to normal.
Last Edit: 23 Jun 2019 22:46 by smg669.
The administrator has disabled public write access.

FCPX stops responding to playback commands. 24 Jun 2019 15:57 #100290

  • Jonathan Levin
  • Jonathan Levin's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 739
  • Thank you received: 18
  • Karma: 5
Turn off background rendering if you haven't already.
The administrator has disabled public write access.

FCPX stops responding to playback commands. 24 Jun 2019 18:55 #100291

  • PaulG
  • PaulG's Avatar
  • OFFLINE
  • Gold Boarder
  • Posts: 193
  • Thank you received: 22
  • Karma: 3
Your project may be corrupted somewhere. Here's a way to force FCPX to clean things up:

Create a new Library
Open Old Library
Copy all of the contents from the old Library into the new Library
Close the old Library
Try editing in the new Library.

Sometimes I've found there's some kind of deal-breaker corruption that is solved by copying everything to an empty new library.

Good luck!
The administrator has disabled public write access.

FCPX stops responding to playback commands. 24 Jun 2019 23:59 #100293

  • tpf1952
  • tpf1952's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 62
  • Thank you received: 3
  • Karma: 0
I share the experience of Stasinos: any kind of video will not roll, it’s not just FCPX. Even if I click on a You Tube , Vimeo or a Quicktime movie: it ain’t gonna roll until after I shut down and restart. I’m intrigued by the suggestion that I disconnect my external audio card, which in my case is a Duet 2.

I had wondered if this was happening to anyone else. So if I’m crazy, it’s gotta be another reason.

Thanks,

Tom
The administrator has disabled public write access.

FCPX stops responding to playback commands. 28 Jun 2019 13:48 #100324

  • thewitt
  • thewitt's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • Thank you received: 1
  • Karma: 0
I have this problem if I'm using a bluetooth speaker for audio output.

If I use my headphones instead, or an external speaker plugged in to the headphone port, it doesn't happen.
The administrator has disabled public write access.

FCPX stops responding to playback commands. 03 Aug 2019 23:05 #100726

  • raphael
  • raphael's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 1
  • Karma: 1
Thanks for all the feedback on this issue. I tried every fix, mentioned here and on Larry Jordan's site. Nothing seemed to help, until I read about the bluetooth connection. I had been using Powerbeats bluetooth headphones for the rough cuts so I don't bother anyone else.

When I switched to powered/connected speakers (Klipsch), the problem went away. Just finished two days of editing a two hour program, and not a single non-responsive event as before. Only time I had to force quit was when the beachball kept spinning for over 5 minutes during creating a composite clip of a 1 hr segment.

Thanks again for all the suggestions.
The administrator has disabled public write access.