Welcome, Guest
Username: Password: Remember me

TOPIC: DriveX Track Portal - clip not starting at its start

DriveX Track Portal - clip not starting at its start 05 Jun 2018 02:04 #95820

  • kindomalay
  • kindomalay's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 44
  • Karma: 0
Hi all,

I have the DriveX Track Portal positioned on main clip. I have a 40 second clip that I've inserted into the portal. I'm seeing a couple of things.

1. The inner clip plays but doesn't start at its beginning, rather about half way through.

2. There doesn't seem to be any keyframing available for the Pan property of the inner clip.

As an aside, I'm thinking the portal grows and then takes over as the main storyline, but at its end, it reverts to the portal again, this way I am using the portal as an introduction to the clip, and back again at the end.

Many thanks for any thoughts.
Cheers
Colin
p.s. Happy to attach screen shots if this needs further elaboration. B)
The administrator has disabled public write access.

DriveX Track Portal - clip not starting at its start 05 Jun 2018 11:20 #95835

  • FCPX.guru
  • FCPX.guru's Avatar
  • OFFLINE
  • Platinum Boarder
  • bbalser.com
  • Posts: 2284
  • Thank you received: 302
  • Karma: 33
I'd recommend contacting Coremelt directly for questions about their products specifically. But having a quick look at the Portal template, seems it is using the built-in Drop Zone feature. In my experimenting just now, seems to start the clip in the Drop Zone on the frame you selected when applying it. Are you seeing something different? I do know from various posts that Drop Zones don't seen to be the most stable or consistent thing in FCPX.

No, there's no Pan keyframing. Drop Coremelt a note and ask for it. They're usually pretty good at responding to requests.
The administrator has disabled public write access.

DriveX Track Portal - clip not starting at its start 05 Jun 2018 17:17 #95847

  • CoreMelt
  • CoreMelt's Avatar
  • OFFLINE
  • Moderator
  • Posts: 50
  • Thank you received: 10
  • Karma: 3
Hi the solution to both these issues is to put the clip you are trying to insert into the portal into a compound clip. Then put that compound clip into the drop zone in the Portal plugin.

The pan parameter is actually a built in FCP X parameter, not a parameter of the plugin, I have no idea why Apple doesn't allow this to be keyframed. However if you go inside the compound clip you can keyframe the transform parameter on your insert clip, this will have the same effect as if you were keyframing the pan,
The administrator has disabled public write access.

DriveX Track Portal - clip not starting at its start 05 Jun 2018 21:08 #95848

  • kindomalay
  • kindomalay's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 44
  • Karma: 0
Hi,
Thank you for the reply.
I'll give your suggestion a try as it makes sense.
From the response below, it seems I can keyframe using transform in the compound clip.
Hurrah!
The administrator has disabled public write access.

DriveX Track Portal - clip not starting at its start 05 Jun 2018 21:10 #95849

  • kindomalay
  • kindomalay's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 44
  • Karma: 0
Hi,
Many thanks for your points. I do have the inserted clip as a compound clip, so I'll try out your suggestion.
I'll also try inserting it with the start frame of the clip as suggested above.
This is great. The power of these forums in terms of evolving knowledge so generously is a wonderful thing.
Thanks again.
The administrator has disabled public write access.
Moderators: funwithstuff, CoreMelt