fcp.co logo transparent
fcp clapperboard
Welcome, Guest
Username: Password: Remember me
14 Nov 2020
Moving over to a new system, we couldn't take the old avatars - so please upload a new one!
  • Page:
  • 1

TOPIC: FCPX 10.2.2 - Still no luck with XAVC-L from Sony X70

FCPX 10.2.2 - Still no luck with XAVC-L from Sony X70 03 Sep 2015 21:21 #67987

  • AndersM
  • AndersM's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 50
  • Karma: 1
  • Thank you received: 4
Hi,

I just updated to 10.2.2 and once again they list "Native support for Sony XAVC-L" in the "What's New" list.

However FCPX still crash when I try to import XAVC-L files from a Sony X70. This is a folder copied to my hdd with the complete file structure straight from the card. The video files plays fine in vlc.

Is anyone using XAVC-L files from the X70 with fcpx successfully?
The files are from a camera with the old firmware, not the new 2.0 update.

Thanks!

Please Log in or Create an account to join the conversation.

FCPX 10.2.2 - Still no luck with XAVC-L from Sony X70 03 Sep 2015 21:24 #67988

  • thefcpxeditor
  • thefcpxeditor's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Control+Command+Awesome
  • Posts: 109
  • Karma: 3
  • Thank you received: 14
Did you also install the new Pro Video Formats 2.0.2 Update? That's really where the support comes from. Also a system restart after the updates might help.

Please Log in or Create an account to join the conversation.

FCPX 10.2.2 - Still no luck with XAVC-L from Sony X70 03 Sep 2015 22:27 #67991

  • AndersM
  • AndersM's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 50
  • Karma: 1
  • Thank you received: 4
Yes, I installed the Pro Video Formats update and did a restart.

Please Log in or Create an account to join the conversation.

FCPX 10.2.2 - Still no luck with XAVC-L from Sony X70 03 Sep 2015 22:36 #67992

  • thefcpxeditor
  • thefcpxeditor's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Control+Command+Awesome
  • Posts: 109
  • Karma: 3
  • Thank you received: 14
Have you tried going strait from the camera/card? Shouldn't need to, but it's an idea. If it's crashing, it may not be a format support thing. May need to do some FCP X troubleshooting. In another FCP X group a X70 user is saying everything works great now. I've tried XAVC-L (from the FS7) in the past and it showed the clips as blank green clips (as it was not supported) it would even import them green. Never had it crash doing that even though the format didn't have support.

Please Log in or Create an account to join the conversation.

FCPX 10.2.2 - Still no luck with XAVC-L from Sony X70 03 Sep 2015 22:47 #67993

  • ddixon
  • ddixon's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 257
  • Karma: 4
  • Thank you received: 47
Yes! Works fine for me. The 2.0 firmware for the camera is required, and once applied you must reformat the SDXC card in-camera, then record new clips. The last FCPX update fixed this for HD - today's update fixes it for 4K. Excellent! This plus the resizable text entry box in the Text Inspector is HUGE for me!

Please Log in or Create an account to join the conversation.

FCPX 10.2.2 - Still no luck with XAVC-L from Sony X70 03 Sep 2015 22:53 #67995

  • thefcpxeditor
  • thefcpxeditor's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Control+Command+Awesome
  • Posts: 109
  • Karma: 3
  • Thank you received: 14
There's your answer, the files need to be from a camera with the 2.0 firmware. In your case, you will have to transcode them to ProRes to use them and then update your camera so that all the future clips work properly.

Please Log in or Create an account to join the conversation.

FCPX 10.2.2 - Still no luck with XAVC-L from Sony X70 04 Sep 2015 02:25 #68001

  • ddixon
  • ddixon's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 257
  • Karma: 4
  • Thank you received: 47
Note that the memory card must also be reformatted in-camera after the firmware update. However, if you have 4K clips that were shot by a 2.0 firmware upgraded camera, those now magically work with 10.2.2. And, before today you could not mix HD and 4K on the same card, but I assume this limitation is no longer the case - although that's an assumption, have not tested it.

Please Log in or Create an account to join the conversation.

FCPX 10.2.2 - Still no luck with XAVC-L from Sony X70 07 Sep 2015 16:22 #68152

  • dfphoto
  • dfphoto's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 103
  • Karma: -5
  • Thank you received: 4
Hi I posted that I am on 10.1.4 fcpx and I simply updated to pro camera 2.02 and I can edit xavc on my timeline with no problems.... fs7 and a panasonic hc-x 4k files.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1