fcp.co logo transparent
fcp clapperboard
Welcome, Guest
Username: Password: Remember me
25 Jan 2021
New boarders will have their posts moderated - Don't worry if you cannot see your post immediately.
Read More...
  • Page:
  • 1

TOPIC:

timeline going black (not all the clips, just some of them) 09 Apr 2016 16:55 #75112

ok, I've read many years ago about a bug in FCPX causing timeline to go black; now I'm facing the problem.
is there a solution to export my work as it sometimes looks ok or do I have to try and do it all over again and hope some clips won't turn randomly black?
this problem is enough to make me switch to another NLE as it is absurd and frustrating.

Please Log in to join the conversation.

timeline going black (not all the clips, just some of them) 10 Apr 2016 03:53 #75117

tell us about which vers. of FCPX you're using (hadn't heard of such an issue with the actual one), and give us some detail about your hardware and your project (settings, source formats, …)

Please Log in to join the conversation.

timeline going black (not all the clips, just some of them) 10 Apr 2016 04:07 #75118

Latest FCPX, latest OSX, iMac 27-inch, Mid 2011, 3,4 GHz Intel Core i7, 16 GB 1333 MHz DDR3, AMD Radeon HD 6970M 1024 MB, 1TB SSD as system disk, but FCPX libraries and footage on a thunderbolt bay with 2 SSDs in RAID.
Sources differ, from some videos recorded with a GH3 to anything else I imported (be it photos or videos from youtube).
From what I noticed it goes black randomly, it might look ok in timeline but exported some go black (videos, but the effect or titles or text remain).
I thought this bug relates to multicam, but the project I was working on was a timeline with overlaid videos (blended as add or soft light or whatever).
I kinda ”solved”, and exported in small fragments, then overlaid videos and set the upper video to blend mode add, but kept the fingers crossed and eventually managed to export all the fragments I needed for this composition.

No, trashing preferences did not work, nor duplicating the project, nor deleting rendered files and all generated media, it goes black all the same, just the video, the effects and text don't.

Please Log in to join the conversation.

timeline going black (not all the clips, just some of them) 10 Apr 2016 07:01 #75119

Can you post some screenshots? Does dumping the cache do anything?

Please Log in to join the conversation.

timeline going black (not all the clips, just some of them) 10 Apr 2016 07:22 #75120

I posted a reply before, not sure if I hit submit or cancel :-) sry
so, I moved the library to another drive, deleted the rendered files, rebooted several times, duplicated the projects, the same problems persisted; no I deleted the initial library so I cannot re-create de issue, as I finished somehow the work and freed space. it was mostly a 1080p footage recorded with GH3 Panasonic and some jpegs; only the effects and titles exported, but the videos beneath were black; I hoped this issue occured only with multicam editing

Please Log in to join the conversation.

timeline going black (not all the clips, just some of them) 10 Apr 2016 07:32 #75121

lightgale wrote: …hoped this issue occured only with multicam editing


ahh, occured only on MCs, that could narrow things...
What Tom asked for:
apply some screen-shots of the project timeline and of the Angle timeline...

only the effects and titles exported


How can effects only been exported??? :blink:
an effect affects the clip applied to .., an effect is no 'content' ....

Please Log in to join the conversation.

timeline going black (not all the clips, just some of them) 10 Apr 2016 07:55 #75122

ups, my bad, I was confused, I put a video of some film burn above the video and blended as add, mistakingly called this ”effect”, only the upper video exported, the video beneath went black; sorry for the confusion
I deleted the library, now I have to dig intro my archives to get some screenshots, or go to sleep :-)
it was no biggie, a home video, but I avoided multicam only to learn that blackscreen occurs elsewhere, too

Please Log in to join the conversation.

timeline going black (not all the clips, just some of them) 10 Apr 2016 11:00 #75129

lightgale wrote: .... put a video of some film burn above the video and blended as add, … , the video beneath went black; …


when done in Angle Editor? Then a 'black' image is correct behaviour, .....
MC is no 'tracks' replacement ..... ;)

Please Log in to join the conversation.

timeline going black (not all the clips, just some of them) 10 Apr 2016 13:51 #75141

when done in Angle Editor?
nope, in timeline, I did not need to sync anything, hence no need for multicam/angle editor
but the turning to black issue happened randomly, the pictures were exported, the video beneath the same ”film burn” video were not;
and moreover, when viewing in timeline sometimes the video first appears ok, then after a while this happens... it might be something with rendering, codec, woodoo stuff, anyways, I was too tired and I deleted my library so now I have a bigger problem :-( but this is just bad user error on my behalf

Please Log in to join the conversation.

timeline going black (not all the clips, just some of them) 30 Apr 2021 15:34 #114242

What worked for me was:
  • Quit FCPX
  • Delete render files for the library that's giving you problems
  • Restart FCPX

Please Log in to join the conversation.

timeline going black (not all the clips, just some of them) 30 Apr 2021 19:25 #114251

  • Ben Balser
  • Ben Balser's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • bbalser.com
  • Posts: 4395
  • Karma: 34
  • Thank you received: 632
Or delete render files via the File menu (much easier and faster).

Please Log in to join the conversation.

timeline going black (not all the clips, just some of them) 30 Apr 2021 20:23 #114254

Didn't work, because render files were not listed as option to delete, just proxy and optimised files

Please Log in to join the conversation.

timeline going black (not all the clips, just some of them) 05 May 2021 02:31 #114324

also, the timeline isn't always updated in real time. It may take a period of inactivity before the storyline refresh task gets enough priority to run.

Please Log in to join the conversation.

  • Page:
  • 1