fcp.co logo transparent
fcp clapperboard
Welcome, Guest
Username: Password: Remember me
14 Nov 2020
Moving over to a new system, we couldn't take the old avatars - so please upload a new one!
  • Page:
  • 1

TOPIC: So this is weird. Clips disappear on timeline, reappear when I zoom.

So this is weird. Clips disappear on timeline, reappear when I zoom. 06 Dec 2016 05:16 #83668

  • noah.leon
  • noah.leon's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
The subject says it all. Editing a 1-2 hour video and as I scroll through, clips to the right on the timeline stop appearing. Basically, they don't appear to be there, no thumbnails, no outline, just empty space, until I zoom in or out, at which point they suddenly appear. I'm putting a link to a video I uploaded which illustrates the problem. Has anyone else seen this? Does anyone know what causes it and have a solution?

It does this on my Macbook Retina, and it did it on my 27" iMac too when I had it, so this is a few versions for me, and the behavior is pretty consistent. I usually import a lot of FCPXMLs from Pluraleyes or Adobe Premiere, if that makes a difference, though I'm not convinced that is the problem (I need more evidence).

I'm working almost exclusively with XAVC-s footage.

The video:


Any help is appreciated.

Please Log in or Create an account to join the conversation.

So this is weird. Clips disappear on timeline, reappear when I zoom. 06 Dec 2016 08:49 #83669

  • Navigator
  • Navigator's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 114
  • Karma: 1
  • Thank you received: 11
Might be a RAM problem?

Please Log in or Create an account to join the conversation.

So this is weird. Clips disappear on timeline, reappear when I zoom. 06 Dec 2016 08:49 #83670

  • ronny courtens
  • ronny courtens's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 4241
  • Karma: 196
  • Thank you received: 896
Hi Noah, welcome to the forums.

It looks like you are cleaning up long videos that were pre-edited, is that correct?

If so, we would need your system specs:

Processor type (i5 or i7)
Amount of RAM
Type of hard drive where you store the media + connection type (USB2, USB3, Thunderbolt...)



- Ronny

Please Log in or Create an account to join the conversation.

So this is weird. Clips disappear on timeline, reappear when I zoom. 06 Dec 2016 11:11 #83674

  • noah.leon
  • noah.leon's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
Thanks for the replies.

I'm using a Macbook Pro 2013 with Retina display, i7 2.2Ghz, 16GB RAM, 500GB SSD, and am editing mostly from a USB3 SSD (although I archive all my stuff on a big slow RAID, I don't use it for editing anymore since I discovered SSDs). Sometimes I have an external monitor connected, but it doesn't seem to affect anything one way or another.

I checked the Activity Monitor to see if all my RAM was being used up, it doesn't seem to be the case based on the "memory pressure" graphic, but maybe that is misleading?

Yes I am editing stuff that was either pre-edited on Premiere or was synchronized using Pluraleyes, but it could also be the size of the project, sometimes I am working with projects which originally had 6hrs of video on the timeline, although the video I am working on right now in the video exhibits the problem and I have trimmed it down to 1.5hrs.

Next project I will try not working from an XML and start the project completely in FCPX to see if that is the problem and report back.

Thanks!

Please Log in or Create an account to join the conversation.

So this is weird. Clips disappear on timeline, reappear when I zoom. 06 Dec 2016 12:47 #83676

  • Ben Balser
  • Ben Balser's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • bbalser.com
  • Posts: 3820
  • Karma: 34
  • Thank you received: 534
Not that specifically, but I have text in the Browser and Inspector vanish until I change something. Happens often on a maxed out MP with T2 RAID. I'm noticing other misc UI visual glitches quite a bit. But I've not had clips vanish like that.

Please Log in or Create an account to join the conversation.

So this is weird. Clips disappear on timeline, reappear when I zoom. 06 Dec 2016 13:44 #83678

  • noah.leon
  • noah.leon's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
Yes I have noticed a lot of little graphical glitches in 10.3, but this problem has been with me since 10.2, and I sort of just assumed it was common and worked around it. I decided to google a solution and found that nobody else is really having trouble with this specific thing, so now I'm doubly curious if I can fix it.

Please Log in or Create an account to join the conversation.

So this is weird. Clips disappear on timeline, reappear when I zoom. 06 Dec 2016 17:40 #83681

  • bogiesan
  • bogiesan's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 218
  • Karma: 1
  • Thank you received: 27
We're running 10.2.+ on maxed out MacPro cylinders. We cannot put any more RAM in the machines and we cannot put faster or bigger graphics cards in them. The right hand edge of the timeline has ALWAYS come onto the screen with parts that are invisible and need time to get drawn onto the screen.
Just seems to be how the app works.

Please Log in or Create an account to join the conversation.

So this is weird. Clips disappear on timeline, reappear when I zoom. 06 Dec 2016 17:46 #83682

  • noah.leon
  • noah.leon's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
Thanks, just a couple questions: the missing parts of the timeline eventually appear in your case? Without doing anything to force a refresh?

And also, are you working with really huge projects, XMLs, and RT Adjustment layers?

Thanks, just trying to figure this out because on my machine, it doesn't ALWAYS do it, only most of the time.

Please Log in or Create an account to join the conversation.

So this is weird. Clips disappear on timeline, reappear when I zoom. 06 Dec 2016 17:49 #83684

  • bogiesan
  • bogiesan's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 218
  • Karma: 1
  • Thank you received: 27
Never really noticed. Just seems like it's always been that way. I'm working on a series now, 10 minute programs, about 200 clips and 8 audio tracks. I can tell you it doesn't matter what the clip height is or how far I'm zoomed in or out.

Did you post this same question over on apple.com? If so, please close out both threads with your solution--if you get one.

Please Log in or Create an account to join the conversation.

So this is weird. Clips disappear on timeline, reappear when I zoom. 06 Dec 2016 17:53 #83686

  • noah.leon
  • noah.leon's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
Yes, I tried Apple too. So far no response on their forum. I think if I can figure out when it starts for me, I might be able to figure out why. Before I just dealt with it, never considered fixing it, but it actually takes a lot of extra time while editing since the only way for me to re-show the clips is to zoom in then out with the keyboard shortcuts.

Thanks for the feedback.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1