fbpx
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Optical flow isn't working properly

Optical flow isn't working properly 06 Jul 2020 22:24 #108511

  • oxband
  • oxband's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 18
  • Thank you received: 0
I'm working in a 24fps timeline. I have these clips show on the dreaded PF24 codec with my Canon camera which means it shoots 24p but exports it as 60i and you need to reverse telecine to get it to look good.

I've been trying to use Optical Flow with clips....but every time I render everything and I go to export....I still always get the message Optical Flow isn't done and the clips sometimes look like it.

I cannot for the life of me figure out this bug but it's driving me nuts. Thoughts?

Please Log in or Create an account to join the conversation.

Optical flow isn't working properly 07 Jul 2020 11:58 #108520

  • joema
  • joema's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1553
  • Karma: 27
  • Thank you received: 331

oxband wrote: I'm working in a 24fps timeline. I have these clips show on the dreaded PF24 codec with my Canon camera which means it shoots 24p but exports it as 60i and you need to reverse telecine to get it to look good....


There are two possible issues: (1) Deinterlace of 60i in in a progressive project, and (2) Rate conforming of 60 in a 24p project.

To achieve this, select a 60i clip in the timeline, then in Inspector select the "i" tab at top, then at bottom select the "settings" view, then select the Deinterlace checkbox.

For that same 60i clip, select the Inspector "video" tab at top, scroll to bottom and under Rate Conform select "optical flow".

These two steps will deinterlace the clip plus select optical flow rate conforming (which is different from optical flow smoothing on a retimed clip).

After that, export the timeline and examine. Deinterlace issues can be difficult to evaluate because some players (inc'l I think Quicktime) will automatically use playback deinterlacing based on clip metadata, so you cannot trust your eyes. It is better to use a tool like VLC which allows manual control over playback deinterlacing. If the clip is properly "hard deinterlaced" in FCPX, when played in VLC with deinterlacing off, subjects with horizontal movement should have smooth edges, not comb artifacts.

Optical flow rate conforming between non-multiple frame rates such as 23.98 and 29.97 or 59.94 and 23.98 will generally improve smoothness and avoid some motion cadence issues. However it is not perfect so you must watch closely for morphing or blurring artifacts, especially of a subject is moving against a complex background.

Please Log in or Create an account to join the conversation.

Last edit: by joema.
  • Page:
  • 1