Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Missing Files-RAID 5 Array issue

Missing Files-RAID 5 Array issue 22 Jul 2020 09:01 #108875

  • DebG.
  • DebG.'s Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 1
  • Thank you received: 0
RAID 5 Array issue.
MacOS (10.14.6 Mojave, Late 2015 27" 5K retina iMac) can't repair the hard drive, copy everything before you're doomed error message when the RAID is plugged into the iMac.

Copied everything to another external hard drive.

Things seemed OK until I opened and FCPX library and random Events had random missing files. I right-clicked on the clips and clicked Reveal in Finder. The clip names were there (such as IMG_7441 [00052601 +2103]) but they're at Zero Bytes.

Also, when I originally imported the files from my SD card, I chose In and Out points to import, like I usually do, never any issues before.

Some of these missing files were part of some completed Projects, Multicam, Compound, and Synced clips so they were originally copied to the Library before the issue with the RAID array.

I tried to re-import from the original SD card without luck.
I even tried to Relink Files with the SD card, no luck, it relinks to the files on the SD card, as soon as the card is removed... poof. It also does not preserve my original in and Out points.

Also tried following this Ripple Training/MacBreak Studio video on "Reimporting From Archives"

Unfortunately, I didn't originally import from a Camera Archive, I originally imported straight from the SD card (I still have the original SD card.)

All the files were modified in one way or another, color correction/grading, audio levels, keywording, etc. and, of course, the editing done on Projects.

I'd hate to have to do all that work again.
Any ideas?

Please Log in or Create an account to join the conversation.

Missing Files-RAID 5 Array issue 23 Jul 2020 09:18 #108895

  • FCPX.guru
  • FCPX.guru's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • bbalser.com
  • Posts: 3595
  • Karma: 34
  • Thank you received: 498
Relink to the original SD card, then perform a Consolidate command on the Library. That will tell FCPX to copy stuff back to the library.

Please Log in or Create an account to join the conversation.

Missing Files-RAID 5 Array issue 24 Jul 2020 14:08 #108915

  • joema
  • joema's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1556
  • Karma: 27
  • Thank you received: 333
Below is the response I posted to the same question on another forum:

You say Reveal in Finder showed zero length files for the FCPX media files (apparently inside the library). This implies the full contents of the library (inc'l those files) were not successfully copied off the failed RAID array -- despite the message "you can still copy files off the disk".

In theory a single drive can fail on a RAID-5 array and the data will be OK but in reality many things can go wrong at file system level or in an application database as used by FCPX or Lightroom. This shows how RAID by itself is not a reliable backup, but that's a separate issue.

Even given the original camera card with intact files, it might not relink to those if FCPX renamed the disk files as part of the ingest. In some cases FCPX will append a "uniquifier" suffix of (fcp1), etc to the file to prevent duplicate filenames. If it does that it might not relink to the original card file because the filenames are different.

Due to the filesystem damage from your disk crash, apparently the disk filenames have also been changed and have a square bracket suffix containing numbers. So you might not be be able to look at the salvaged disk file and see the original disk filename, which FCPX may have itself renamed before the crash.

Here is one thing you might try. If possible rename the current disk drive where the salvaged data and libraries are. Rename it to the original disk name used before the RAID failure. Also place the library and media on the salvaged drive in the same path locations as on the RAID before the failure. Then see if that makes any difference. There is a very low probability of this helping but in some cases FCPX resolves file paths based partially on the drive name. That info is stored in the FCPX library which we cannot change, but changing the drive name to the original name might help (although I'm not optimistic).

If that doesn't work, the only remaining step might be to try filesystem repair or data recovery on the failed RAID. Something about that crash damaged the filesystem, causing the zero-length files. The RAID-5 failover might have protected the data but the filesystem got munged because of an abrupt shutdown. Sometimes that can be fixed. You could either try Disk Utility First Aid or a 3rd party utility like Disk Warrior (which is very good). That only works on HFS+ not on APFS drives.

Don't try that if the data is of such extreme importance that a professional recovery service is warranted. They can sometimes recover the data (at a price) but only if you don't mess it up trying yourself.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1