fcp.co logo transparent
fcp clapperboard
Welcome, Guest
Username: Password: Remember me
25 Jan 2021
New boarders will have their posts moderated - Don't worry if you cannot see your post immediately.
Read More...
  • Page:
  • 1

TOPIC:

FCP 10.5.2 Event Viewer not playing clips 15 Apr 2021 10:37 #113986

Editing platform: iMac Pro 64GB ram 1TB SSD Big Sur 11.2.3 FCP 10.5.2

After fresh start of FCP, the Event Viewer will only play ONE TIME a clip from the Even Browser. After this one time playing, none of the clips play, or even show in the Event Viewer. I have restarted the Mac, ran CleanMyMac X to optimise, but nothing makes a difference. I have Default Workspace loaded.

Just to prove I am not going mad, I opened my M1 MacBook Air, which shows any and all clips in the Event Viewer.

This basically makes it impossible to cut video on my iMac Pro at the moment. Any suggestions?

Please Log in to join the conversation.

FCP 10.5.2 Event Viewer not playing clips 15 Apr 2021 10:42 #113987

Ok, so I've fixed it by restarting FCP with Option+Command keys held down to delete preferences!

Anyone else had a similar experience? Can you explain what was happening?

Thanks,

Please Log in to join the conversation.

FCP 10.5.2 Event Viewer not playing clips 15 Apr 2021 21:25 #113997

Well, I've spoken too soon. The problem comes back as soon as I open a project! WTF???
I can't edit now on my iMac Pro. Grrr...

Please Log in to join the conversation.

FCP 10.5.2 Event Viewer not playing clips 15 Apr 2021 23:19 #114001

Have you tried reinstalling FCP? I never use any 'clean my Mac' software but heard they sometimes cause more harm than good.

Please Log in to join the conversation.

  • Page:
  • 1