fbpx
✎ Latest Forum Posts
✎ Latest Free FCPX Effects
Dimitrios replied to the topic 'New MacMini suitable for editing?' in the forum. 10 months ago

Hi guys. I didn't want to start a new thread since this one is relative.

Do you think that an i7 mac mini with 32 GB Ram would be a nice replacement to my 2015 27" iMac (i5, M390)?
I am editing TV shows in FHD and exporting in the MXF format (25i). With my present machine i don't need to use proxies.

Will the lack of a proper GPU introduce significantly slower render and export times?
I am not looking for a faster machine, just a replacement.

Also, do you have any suggestions for a 4K monitor?
Read More...

Raphael Sason thanks user 'Stasinos' in the forum message ' FCPX stops responding to playback commands.'. 11 months ago
Dimitrios replied to the topic '2018 Mac Mini and eGPUs' in the forum. 1 year ago

le realisateur wrote:

I just bought the high End Mac mini with an external e-GPU from Razer with a Radeon Vega 64 GB. It is like having a baby Mac Pro. This combo is perfect with FCPX. Works like magic. I kept my dual 4k displays. and plugged all my thunderbolt 3 drives. ( upgraded from a hackintosh ).

No issues at all.
Here is a Geekbench result.

Hi le lealisateur! I am considering the exact same setup (working on an iMac 5K late 2015 right now). After 5-6 months of use are you still happy with this combo? Is that EGPU solution reliable while working with FCPX?
Read More...

Dimitrios replied to the topic 'FCPX stops responding to playback commands.' in the forum. 1 year ago

I have a similar problem. In my case no video file will play in FCPX, VLC, Quicktime and even Safari. Until last week the only workaround was to restart my computer.

This week i tried to unplug and plug again my external audio device (M-Audio M-Track) and the problem was solved. If i switch to internal audio card from the settings the problem also disappears. So in my case it has to do with the Mojave update along with external audio.

I have also serious bluetooth connection problems (after mojave update) as my magic mouse and keyboard tend to disconnect after waking up from sleep.

Do you have an external sound device connected?
Read More...

Dimitrios replied to the topic 'MXF export issues' in the forum. 1 year ago

Algowin wrote:

Good day
I have the same problem
I have all the latest
And I Nead to export 3 hour program in 25 frames
Never worked
Although I don’t see the problem when opened in pc it’s there

I deliver in mov but it’s a big problem
Please help

Hi Algowin. Given the fact that this issue usually appears in export longer than 40 minutes, a 3 hour export seems almost impossible to me. One way to get around this is to ask your client if it's possible to deliver this in 4 parts. In this case you will split your edit in 4 different projects and export them separately.

If this has be a single file, then you can export a ProRes Master file and then covert it to MXF. I suppose Compressor will have the same issue as it has the exact same engine with FCPX, so you can use Premiere or any other NLE to convert this.

It's a PITA, I know....
Read More...

Dimitrios replied to the topic 'MXF export issues' in the forum. 1 year ago

petersxs wrote:

Yes Stasinos, this has to be addressed !! What framerate do you work with ? 25i ? i have not found out yet if the error is only in 25i and maybe not with 30 fps . There was a interlaced bug with MXF some time ago with wrong field interpretation , which took quite some time to repair ! this error was only in 25i , so if its not in 30 .... america first ;) .. Taking into account that the iPhone 7 camera, apples own app !! still can't record with 25 fps , we can see how nit they care about Europe...

Could everybody who has got this issue please state the framerate/ codec ? And please always note in Bugreports etc

in the meantime i hav efound a way to alte least identify a broken file without having to loo at the whole movie .
VLC player ! once it gets across an error it will show a broken frame till the end (similar to what is posted ). quicktime player does not!

Hi Peter, i am always working with 25i. I am also using VLC to preview the file. As you said, using VLC it's easy to find the breaking point. But in this specific case it doesn't matter, as it's not a problematic frame that causes the issue. It's very random. One time it happened in the last 30 secs of a 45 min MXF and i finally managed to get a healthy file after 2 days. What a nightmare... This issue, along with annoying bluetooth connectivity issues after sleep (keyboard & mouse) that came with Mojave destroys the whole purpose of using a Mac for me.
Read More...

Dimitrios replied to the topic 'MXF export issues' in the forum. 1 year ago

petersxs wrote:

ps: its happening with compressor too, so the export in Prores and convert to MXF route des not work reliable anymore . you must control the whole program to find out, the longer the programm the more likely you will get this.
the most reliable, and NO error on the QC of the TV station ist the FCPX 7 XDCAM DISK route.....

Hi Peter, yes this is unacceptable. Ronny and Kolanko gave us some valuable workarounds that may work some times. I have noticed something that may also help some of you. After the latest updates, my first attempt to export my MXF file is always successful. But if i try a second export then it will be corrupted 9 out of 10 times.

At this time (a short time after the first export) whatever i try (restart, copy to another timeline etc) i know that i am not gonna have a healthy file. So i am trying again after 5-12 hours and this is where i am finally getting it. I think this a rare combo issue, a software bug that is closely related with GPU's temperature.

Whatever this is, Apple has to investigate this because MXF is still in use by many large TV stations.
Read More...

Dimitrios thanks user 'Kolanko' in the forum message ' MXF export issues'. 1 year ago
Dimitrios thanks user 'ronny courtens' in the forum message ' MXF export issues'. 1 year ago
Dimitrios replied to the topic 'MXF export issues' in the forum. 1 year ago

Kolanko wrote:

We updated one machine to Mojave 10.14.3 and FCPX 10.4.5 and it still happens. It is a lot better as it doesn't happen that often, but still does. What i find strange is that this topic is the only one i have found about this issue. It seems that almost nobody experiences that...

Hi again Kolanko. Yep it still happens some times. I saw no reference to this on the web so i started this topic to see if there is a workaround. It seems that mxf is not widely used anymore by editors so the feedback on this bug is minor.

This is definitely a software bug and a very time consuming one. It costs me a great amount of time and money when it happens so i understand your frustration.

Apple MUST address this. At least they can search for the reason behind corrupted MXF exports and suggest a workaround. I did contact them through their support page and never got a response.
Read More...

Dimitrios replied to the topic 'MXF and Audio Roles' in the forum. 1 year ago

Dhruv FCPX wrote:

Hi Guys
After exhausting trials I have come to the conclusion that doesnt matter what you do to the audio on FCPX 10.4 timeline, if you send it to Compressor to make a MXF ( XDCAM HD) file the resulting file will only give you MONO audio!! There is NO option to change the audio to Multitrack at all. If I make a Uncompressed 1080i
25 frames I get that option and it delivers Stereo audio...Does anyone know whether this is a bug? Is there
any solution as my broadcaster only accepts XDCAM HD 422 50 Mbps MXF file with stereo audio. Please someone help.

I was also trying to export a stereo MXF but then i realised that the TV station was converting any stereo file to dual mono anyway.

Since FCPX's exporter refuses to export a stereo MXF and Compressor has only dual mono as an option i am curious to see a solution to this.

If the TV station doesn't accept dual mono audio (i can't see the reason though) you have always the option to export an audio master file and send this separately. To my knowledge, almost any server can digest video and audio as separate files.
Read More...

Dimitrios replied to the topic 'MXF and Audio Roles' in the forum. 1 year ago

Dhruv FCPX wrote:

In above solution is the resulting file a MXF file with XDCAM HD 422 50 Mbps?
What are the settings please?

You will need Compressor for this to work. Open Compressor and you will find the exact same destination that you where using inside FCPX. In this case it's XDCAM HD 422 50 Mbps (it is located inside the MXF folder on the left window of compressor which is the preset library).

Duplicate this preset, rename it to something like MXF dual mono and then go the audio tab and change the configuration from 8 mono to dual mono. That's it. Open FCPX and load the preset as a destination.

From now on you can use this destination instead of sharing a master file.
Read More...

Dimitrios replied to the topic 'MXF export issues' in the forum. 1 year ago

Kolanko wrote:

I have exactly the same issue on all computers in my company (6). I am using FCPX 10.4.4, compressor 4.4.2, and OS High Sierra (4,2 GHz Intel Core i7, 32 GB 2400 MHz DDR4, Radeon Pro 580 8192 MB). I highly doubt its a hardware issue. TV station which we are working for is only accepting MXF files so this is a huge issue for us. The longer the clip the higher chance of this happening.

Hi Kolango. Thanks for your reply. Indeed this is a real problem that caused me many headaches and frustration.

Since i moved to Mojave 10.14.2 and FCPX 10.4.4 i have exported 5 timelines (45 min. long) successfully. I am not
sure though if this has been fully addressed.

As much as i love this app it is a real nightmare when it comes to exporting.

P.S. I made a custom MXF preset using compressor and i am using that for exporting since FCPX's MXF exporter in the latest version refuses to export dual mono mxf.
Read More...

Dimitrios replied to the topic 'MXF and Audio Roles' in the forum. 1 year ago

An editor suggested a simple solution which seems to solve this problem. I didn't know that Compressor and FCPX share the exact same export engine.

So i created a custom setting in Compressor (MXF with 2 discrete channels) and then loaded this as a destination in FCPX. Now i can export anything in this setting directly from FCPX without re-encoding.

What seems strange though to me is that some of you didn't have this issue in 10.4.4.
Read More...

Dimitrios replied to the topic 'MXF and Audio Roles' in the forum. 1 year ago

This is what i am always using too. Broadcast MXF
Read More...

Dimitrios replied to the topic 'MXF and Audio Roles' in the forum. 1 year ago

Doug wrote:

I think your best bet would be to export a ProRes Quicktime .mov and then create your MXF file using Compressor, rather than creating a multitrack MXF which is why this is happening for you.

Thanks Doug, this is definitely a solution but it will double my export times as this a 45 min. long tv show.
Read More...

Dimitrios replied to the topic 'MXF and Audio Roles' in the forum. 1 year ago

I am attaching 2 screenshots from my exporter and the file i am getting (imported in FC)


[File Attachment: Export.png]

[File Attachment: FinalFile.png]
Read More...

Dimitrios replied to the topic 'MXF and Audio Roles' in the forum. 1 year ago

Thanks Tom, sadly whatever i set, the final export has 8 mono channels. My project is set to stereo and even if i choose to export a single stereo audio channel (with all the dialogue roles in it) in the exporter, my file will have 8 mono channels. This is starting to drive me nuts. Maybe a 10.4.4 bug?
Read More...

Dimitrios replied to the topic 'MXF and Audio Roles' in the forum. 1 year ago

Tom Wolsky wrote:

If I export MXF with two mono audio channels based on roles I get two tracks. I'm not seeing eight channels in the QT player or on reimport to 10.4.5.

Hi Tom! Are you exporting an mxf master file from FCPX? Can you please attach a screenshot of your configuration in the roles tab of FCPX's exporter? I would really appreciate it. Thanks!
Read More...

Dimitrios replied to the topic 'MXF and Audio Roles' in the forum. 1 year ago

I wrote too much before so i will sum up the issue in one sentence in case that someone can help.

Since 10.4.x version I can't export a dual mono audio mxf file. Everything i am exporting is 8 mono.

Is this normal? Thanks again guys!
Read More...