fbpx
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Need Compressor 4.4.2

Need Compressor 4.4.2 02 Mar 2020 22:19 #105114

  • Mican
  • Mican's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 1
  • Thank you received: 0
Hi I have Mac os High Sierra and am trying to send to Compressor from Final cut pro version 10.4.6 There I am told I need Compressor ver. 4.4.2 Anyone who known s where to download the 4.4.2 version.

Please Log in or Create an account to join the conversation.

Need Compressor 4.4.2 04 Mar 2020 13:56 #105177

  • FCPX.guru
  • FCPX.guru's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • bbalser.com
  • Posts: 3448
  • Karma: 34
  • Thank you received: 474
What version shows up in the App Store for you?

Please Log in or Create an account to join the conversation.

Need Compressor 4.4.2 06 Apr 2020 20:55 #105955

  • zfp
  • zfp's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 1
  • Thank you received: 0
Hi. I'm facing the same issue. My Compressor version is 4.4 and the current App Store version is 4.4.6 (Catalina). The update doesn't work. I switched recently from Sierra to High Sierra and could update FCP. App Store proposed me not the last version 10.4.8 compatible with Catalina but an older one (10.4.6).
Even if the Compressor version 4.4.2 should be compatible with High Sierra, I wonder if my MBP (early 2011) allows this.
Any idea ?

Please Log in or Create an account to join the conversation.

  • Page:
  • 1